Known Issue - as of the 11/3/2020 update Google Classroom scores may not correctly import Points Possible - Fixed 11/5/2020

UPDATE: The fix for this shipped 11/5/2020. It will correct all Assignments that are missing Points Possible in GBS.NP

As of the 11/3/2020 update Google Classroom scores may not correctly import Points Possible. The Imported Assignments will show Points Possible but it does not add Points Possible to each Student. 

Manually adding the Points Possible will correct the calculations. An update will be coming out soon that will correct all Assignments that are missing Points Possible in GBS.

1 person likes this

Not sure if this is helpful or not but if a teacher just imports one assignment at a time the import seems to work correctly but if they update multiple assignments all at once it only imports the student's score. The # correct possible, points possible and points earned are zeroed out.

If you go to 'edit' assignment in Aeries it still has the # correct possible and the points possible. I had to zero these out on the assignment, then re-enter them to remove the grey fields and re-populate them on the 'enter scores' page. This still didn't correct the points earned. Re-entering the individual scores worked or, at this point re-importing from Google Classroom worked, on just a single assignment.

If you need any sample gradebooks I have quite a few.

Our High School is also experiencing some issues with google classroom and assignment imports. 

One teacher reported that 

After syncing my grades today, I had a weird thing happen.  The grades that were imported were now grayed out (see below). Even though there are grades here and impacting their overall percent it seems the same way, students are seeing on their end that the assignment is missing. I've changed nothing in my settings or how I do things in Google Classroom or Aeries, but I imagine it has something to do with the import.  Do you know what is happening here and how I can fix it?


Screen Shot 2020-11-05 at 8.44.31 AM.png

2 people like this


That is exactly what I received from one of our middle schools. They are saying that its graying out for students who did the assignments. 

2 people like this

This sql query will fix the gradebooks but if they push the import assignment button it will mess the gradebook up again.


update gbs


set =, = convert(money,, =,gbs.SCR = convert(money,, gbs.pc = (*100


from gbs

inner join gba on = and =

inner join gbk on =


where <> and <> 0 and (gbs.scr = 0 and <> '')and not in ('NA','TX')

  and gbs.del = 0 and gba.del = 0 and gbk.del = 0

  and gba.EI like 'google%' 

Same thing is Happening to us, We are hosted also, so we cannot apply an SQL Fix

1 person likes this

Aeries released revision notes this morning that says this was fixed in the update last night

1 person likes this

We are hosted.  This is happening to us also.  When is a fix expected.  Students see that their grades are missing.  This is causing headaches for many teachers and students.

I installed the update this morning and can confirm that it fixes the issue.

Login to post a comment