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Session Description:   Learn how to automate the creation of interactive data visualizations using 

Microsoft Excel to make it easier to access data to help inform important decisions at your school or 

district.  This is a “How to” example of test data analysis using Aeries’s query results and Microsoft 

Excel.  We will cover how to collect, join, format, display and refresh data using MS Excel’s Get Data, 

Power Query Editor, Pivot Tables, Pivot Charts and Slicers.  

 
 

1. Export query results from Aeries into Microsoft Excel  
Automate using Get Data 
 

2. Use Power Query to join and format the data. 
Pivot Columns to create one row per student 

        Merge multiple queries 
 

3. Use MS Excel to Analyze Data 
                          PivotTables 
                          PivotCharts 
                          Slicers 
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Step 1:  Export query results from Aeries into MS Excel 
 
This example will use two queries from Aeries. Follow the steps below to run each query and save to 
MS Excel. 
 
Login to Aeries > navigate to the Query Screen 
Copy Query 1 and paste directly into the Query screen. 
 
 
Query 1 - Student Demographic  
 
LIST STU LOC STU.SC LOC.NM STU.GR STU.ID STU.NM STU.SX STU.LF? STU.HL? STU.ETH? STU.RC1? 
 
Be sure to check Include Inactive Students 
 
After pasting the query text into Aeries Query, run your Query in Aeries by Clicking on the Excel 
Button. 
 

 
 
When the query results are ready to be viewed, you will see the dialog box below. 
 

 
 

Click on the View Report Button to open results using MS Excel. 
When prompted to open the file Click the Open Button. 
  
  
 
 
After opening MS Excel workbook, Click on the Enable Editing Button at the top. (In Yellow) 
 

 
 
 

Click on File > Save As > (Choose desired location) & name the file Demographics.   
Click Save & close the workbook.      
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Repeat this same Query process from the beginning for Query 2.   
 
 
Query 2 - SBAC query for a specific school year  
 
LIST STU TST CST CSN CTL STU.ID TST.ID TST.TA TST.GR CTL.NM   
(( IIF ( TST.PL = 1, "1 - NOT MET", IIF ( TST.PL = 2, "2 - NEARLY MET", IIF ( TST.PL = 3, "3 - MET", 
IIF ( TST.PL = 4, "4 - ABOVE", "No Test Data" ) ) ) ) )) IF ( TST.ID = SBAC AND ( TST.TA = 
"SPRG22" ) )   
 
*Note if you get an error you may need to remove a space at the end of a line & then click the 
spacebar after the end of the query as cut/paste may insert a space. 
 
This Nested IIF statement query will convert Proficiency Levels 1,2,3,4 to the phrases, 1 - NOT MET, 2 
- NEARLY MET, 3 - MET, 4 – ABOVE, and “No Test Data” to indicate that there is no value for the test 
for both ELA and Math Proficiency Levels.   
 

 
 
Save the query results as a MS Excel spreadsheet with the name SBAC. Close this workbook. 
 
 

 
Use Microsoft Excel Get Data 
 
Open a new blank Excel workbook & save this workbook as SBAC Analysis.   
If you haven’t already, close the workbooks you created from the 2 queries above.  
 
The next steps will create a connection to the 2 workbooks we saved containing our query data from 
Aeries.  Using this Get Data feature in MS Excel will enable us to automate the refresh of our data & 
to utilize the Power Query Editor to join and format our data. 
 
In MS Excel, click on the top menu item Data > Get Data 
Choose From File > From Excel Workbook 
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Navigate to the location where you saved the 2 query workbooks.   
Select the Demographics.xlsx file and click the Import button.  Note:  you are only able to Import 
1 file at a time. 
 
From the Navigator window, select the Demograpics Sheet1 workbook.  The data will then appear to 
the right.  Click on the Load button 

 

 
 
The data has now been loaded into MS Excel as a Table.   
Rename the table Demographics on the right side under Queries & Connections. 
 

  
 
 
Follow the same steps to import the SBAC workbook & rename the Query to SBAC. 
 

 
You will see each workbook in a separate tab and a summary of the data in the Queries & 
Connections section on the right-hand side of the screen.  
 
Tip:  Leave worksheets named Sheet 1 in the original Excel Workbook & at the bottom tabs of the 
SBAC Analysis workbook. Otherwise, when you Refresh the data you will need to make sure the 
worksheet tabs have the exact same name. 
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Step 2:  Use Power Query to Join and Format the Data 
 
To join the data from the 2 Tables, we first need to pivot the SBAC data so there is one row of data 
per student.  Microsoft Power Query Editor makes this easy!  
 
Click on the SBAC tab. 
Click on Query on the top menu and then Edit. 

 

 
 
The MS Excel Power Query Editor opens with a whole new world of possibilities!  Notice that we 
see All of our data tables, or queries, on the left.  Make sure the SBAC query name is highlighted. 
 

 
 
 
Click on Transform from the top ribbon. Click on the Test Title column header to highlight the 
column.  Select Pivot Column from the Transform menu. 
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This option will use the values in our selected column to create new column headers. 
Select PerformLvl field in the values column.   
Click Advanced Options and select Don’t Aggregate, Click OK. 
 

 
 
The SBAC data has now been flipped, or pivoted, to only have one record for each student. 
There is a separate column for English Lang Arts & Mathematics with performance level for each 
student. 
 

 
 
Click on the Home menu tab at the top. 
Click on Close & Load 
This saves the changes to the SBAC table and brings us out of the Power Query Editor. 
 

 
Use Power Query to JOIN Data 
 
Now we are ready to join or Merge the data from the 2 separate Queries into one table. 
 
Click on The Demographics Query to see the Query menu option in the top toolbar. 
Click on Query 
Click on Merge 
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Select the following options to join the Demographics table to the SBAC table on Student ID.   
 

 
 
Click the OK button. 
You now see a new Query named Merge1 with a column added to the end named SBAC. 
However, the values displayed for each record = ‘Table’ 
 
To show the actual data, need to click on the icon with arrows in the column header name and 
choose Expand.  
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Note:  you only need to expand the fields you want to see in this merged table.  Since we already 
have Student ID in the table from Demographics, I unchecked Student ID. 
 
Click the OK button. 
 
The SBAC Test result fields have now been added to the end of this table. 
 
There are now 3 Queries available.  Right-click on the Merge1 query name on the left and rename 
to SBAC Demographics.  
 
From the Home menu select Close & Load to save. 
 
 
 
 

Use Power Query to Format Data 
 
We also need to format the data to make our visualizations better.   
 
Launch Power Query Editor either by selecting Query from the top menu OR  
Data > Get Data > Launch Power Query Editor. 
 
Click on the SBAC Demographics table. 
 
Rename columns to display better on your visualizations. 
For example, right-Click on the Description_STU_LF column header and select Rename. 
You can then begin typing to change the name.   
Change the name of the column to Language Fluency. 
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Repeat this process for any fields you would like to rename. 
 
Explore the values in the fields.  Replace null values with a better option. 
For example, in the Language Fluency, Home Language and Race columns replace null values 
with Unknown. 
To do this, right-click in any cell of the column & select Replace Values. 
Enter null as the Value To Find. 
Enter Unknown for the Replace With value. 
 

 
 
The Grade column comes from the test grade field (TST.GR) and has a zero after each grade.  Use 
Replace Values to change each grade.  Replace 110 to 11, 110 to 10..etc.  
 
 
From the Home tab, click on Close & Load to save these changes. 
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Step 3:  Use Analyze Data with Pivot Tables and Charts 
 
 
Pivot Tables and Pivot Charts are powerful tools for analyzing data.  We can create both a PivotTable 
and a PivotChart using our new SBAC Demographics table by selecting the Insert tab on the 
Ribbon and Clicking the PivotChart Button & selecting PivotChart & PivotTable. 
 

 
 

The Create PivotTable Dialogue Box appears.   
 
Ensure the Table/Range is SBAC_Demographics and the New Worksheet radio Button is selected.  
Click the OK Button.  

 

 
 
 
This will create a new worksheet in the workbook with a placeholder for the PivotTable. 
Name this worksheet SBAC Analysis by right-clicking with the mouse on the new Sheet tab.  
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Notice the PivotTable Fields control box on the right-hand side of the worksheet.  This is where you 
control what is in the PivotTable.   
 

      
      

 
Adding Fields to your PivotTable is as easy and clicking and dragging.  To count the number of 
students in our data set Click the check box next to the Student ID field.  This will add that field 
under the VALUES category.  This is the box that performs calculations in a PivotTable.  By default, it 
will Sum the value.   

 

 
 

To get the total count of students instead of adding the student ID numbers together, Click on the 
drop-down arrow next to the “Sum of Student ID Field”.  Select Value Field Settings and the 
Value Field Settings dialogue box will appear.  
 
 Select Count and Click OK. 
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It is usually better to analyze percentages instead of counts of the data. To turn the count of students 
into a percent of students, drag the Student ID to the Values box again.  This time, in the Value 
Field Settings select the Show Values As tab and chose % of Column Total from the drop-down. 
Click on the Number Format button to format the data as a percent with 0 decimal places. 
 

 

 
 

Select the following Fields one at a time. Drag and Drop them into the Row or Column boxes as 
shown in the image below.  

  

 
 
 

Note, I removed the count of student by dragging the field from the Values box back to the tables box 
above. 
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The PivotTable on the left side of the screen will look like this. 
   

 
 

 
On the left, is the ELA Proficiency Level.  Across the top is the grade level the student took this test.  
The numbers in the PivotTable represent the percent of students that fall within each category. 
 
The PivotChart is also displayed.  Use Quick Layout and Chart Styles for a quick and easy way to 
create great looking charts without having to spend a lot of time formatting.  
 
While the PivotChart is selected Select the Design Tab. Choose the Quick Layout Button to select a 
preformatted layout. You may also select a Chart Style.   
 

 
 
Repeat these steps to add a Pivot Chart for the Math Performance level on the same worksheet. 
 

Add Slicers 
 
Slicers allow you to quickly filter the data in both the PivotTable and PivotChart by clicking on Slicer 
(filter) Buttons. 
 
To insert Slicers.  Fist Click anywhere on the Pivot Table or Pivot Chart.  Then Select the 
PivotTable Analyze tab on the Ribbon.  Click on the Insert Slicer Button in the Filter Group.   
 

 
 
The Insert Slicers dialog box will appear. 
 
Check the fields you want to be able to Filter by and Click OK. 
The slicers will be created.  Move and resize the slicers on your spreadsheet.   

 
 

 
You are now able to filter your Pivot Table and Pivot Chart by Clicking the items on the slicers. 
 
Tip:  To use one set of slicers for multiple Pivot Tables or Charts, Select a slicer.  Select Slicer tab 
on the ribbon and Report Connections.  Check the visualizations to share this slicer. 
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Step 3:  Analyze Data  
 

 
 

 
 
Use the Slicers to filter the data. 
 
Drill Down to see a list of students.  When you right-click on any of the bars in the chart and select 
Show Detail a new worksheet will open listing the students who meet the criteria. 
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Refresh the Data in 3 Easy Steps! 
 
Once you have this setup, all you need to do is re-run the queries & refresh the data.  No joining or 
formatting required! 
 
1. Run Aeries Queries - Re-Run queries to get the latest data. The SBAC query will need to 
modified to add the new test administration: 
  
LIST STU TST CST CSN CTL STU.ID TST.ID TST.TA TST.GR CTL.NM  (( IIF ( TST.PL = 1, "1 - NOT 
MET", IIF ( TST.PL = 2, "2 - NEARLY MET", IIF ( TST.PL = 3, "3 - MET", IIF ( TST.PL = 4, "4 - ABOVE", 
"No Test Data" ) ) ) ) )) IF ( TST.ID = SBAC AND ( TST.TA = "SPRG22" OR TST.TA = "SPRG23" ) )  
 
2. Replace - Save each new query result to Excel. Navigate to where you stored the original data & 
select the existing file to REPLACE the data.  Close each workbook. 
 
Note:  You could just run the query for the new test administration each year.  Instead of replacing 
the SBAC workbook, you would cut & paste the new data to the end of the existing SBAC file and 
save.  
 
3. Refresh - Open the SBAC Analysis Workbook. Click on the Data tab on the ribbon & Refresh All.  
You will now see Spring23 data in the SBAC Demographics table. 
 

       
 
 
Select the Pivot Chart and PivotChart Analyze from the ribbon and Refresh All. 
 

 
 

The Charts are now updated.  We can see data for both testing administrations. 
 

 


